We welcome your comments on OpenSolver.

647 thoughts on “Feedback”

  1. I’m currently dealing with the error that refuses to allow me to sign in with Google. I understand this has been a known issue since February, and I was curious if there had been any updates to that.

    1. Unfortunately, we have not had the resource to address this. It is proving to be very frustrating. Google has changed something, and our experts have not been able to identify any calls in the code that trigger the supposed permissions requirement. Sorry for the inconvenience; we will hopefully have a student available in Dec/Jan/Fed to look again at this. We would welcome any volunteers to help with this. Andrew

      1. I have the same issue with Google Sheet permissions. Are there any alternatives to Open Solver and Solver for Google Sheets?

  2. Good morning OpenSolver team
    I have found that when I change the order of the data in an Opensolver model, for a transportation problem, the results also changes.
    What is the explanation about this?
    Please I need a soon answer.

  3. Hi,
    Your tool is so powerful and amazing and it did help me solve a very complex linear program with like 300 variables. You can’t believe how much I appreciate that.
    But there still exists a problem that the sensitivity analysis can’t be done and even those options can’t be chosen because that area is grey as a whole and seems disabled. Do you have any idea what can’t be done about that? I am now totally confused.

    Yours Sincerely

    1. Perhaps you have integer variables? If so this disable sensitivity analysis. Andrew

  4. Hi there,

    open solver is a great tool and I use it a lot!

    I’m working on an LP Model and after solving the windows shows up “No Feasible Solution”

    Nevertheless, the solution looks feasible to me. It maximizes what I wanted and all restrictions are complied. The model I’m solving is linnear (at least OpenSolver didn’t point otherwise).

    Can you help me?

  5. Dear OpenSolver team,
    I tried using OpenSolver’s API, and I am encountering an issue with the function SetQuickSolveParameters. For example, I ran

    Sub Open_solver_quick()
    Set par = GetQuickSolveParameters ‘line 1
    SetQuickSolveParameters (par) ‘line 2
    End Sub

    Line 1 ran fine, but line 2 generated ‘Runtime error 424: Object required’. What is the right way to pass the parameters to SetQuickSolveParameters?

  6. Dear Opensolver Team,

    Thanks for a great product. Do you have any solution for this problem? Gurobi used to work fine for me last month. Just in case I have downloaded the new license but such error pops up.

    I appreciate any help 🙂

    Error -2147220504: The Gurobi solver did not complete, but aborted with the error code 1.

    1. Gurobi have updated their software and Python version; please try out our 2.9.3 beta release which fixes this, we hope. Please let us know how 2.9.3 works for you. Andrew

      1. Hello.

        I had a similar problem with JJ and the 2.9.3 beta release solved my case.

        Thank you for making this program freely available.

  7. Hi,
    I sincerely appreciate your generosity in making this program freely available. In my problem, one of the constraints is not solved, but open solver is showing an optimal solution (LP problem). Any suggestions on how to rectify it?

  8. Dear OpenSolver team,
    I rely heavily on the OpenSolver in Google sheets, but is it still broken? What is the status? Any improvements? API problems? Google not consenting the plugin?
    I believe now that my problem with no more working Solver wasn’t related to the if() formulas I used but rather to the moment, I got my solver kicked out by Google… This is really bad, since I don’t use Excel at home, have rewritten everything from G-sheets to LibreOffice StarBasic and then found out, the solver model will not be saved into the sheet. So OpenSolver plus LibreOffice makes no sense at all…
    And my online application ceased working. Too bad!
    Greetings Kai

    1. We have gone thru the new Google approval process, but something is it working yet despite Google saying the app is now approved. We are asking them to advise on next steps. Sorry this is proving to be such a tortuous hurdle to jump thru. Andrew

  9. Hello,
    first of all thanks for Opensolver (i’m loving it!) – while developing an assignement model, i came across the need for using AddConstraint API: if calling it as Application.Run(….) Excel says the macro doesn’t exist/it’s not available…but if i go into the API VBA module, copy AddConstraint and rename it as for example AddConstraintFC, the new one works flawlessly! No big issue (i just need to save Opensolver.xlam, though i did not understand well the messages about exporting, tidying up etc and i would like to keep “clean” the xlam file), just sharing as maybe it may be interesting for other ppl and/or easy to fix. thanks again& ciao, Francesco

    1. Thanks for the tip. Most odd. Maybe adding a new function refreshed some list somewhere? Did the original method work after adding the new one? Andrew

  10. Hello OpenSolver team.

    I love OpenSolver! This is much more powerful than the EXCEL built-in Solver.
    I had one problem about SATALIA SolveEngine. I clicked the “revoke” key in Satalia Dashboard by mistake. When I use the Satalia Using SolveEngine, it showed up with below message:
    OpenSolver 2.9.0 encountered an error:
    Invalid API key, please check at

    I tried unloading Open Solver and deleting all the files, but it didn’t work – the same message pops up.

    I didn’t find a place to update the API key of Satalia using SolveEngine.

    Could you please do me a favor?

  11. Hello OpenSolver team!

    Thanks to the great product! Open Solver is more than 10 times faster than the Excel built-in solver. I love this product!

    But I have one question about SATALIA SolveEngine. I somehow clicked the “revoke key” button in SATALIA dashboard. Now when I tried to use SATALIA solveEngine, it popped up invalid key. How can I solve this problem? I tried deleted Open Solver from my computer, but it seemed to remember the SATALIA key, and it still showed “invalid key“. How can I update the SATALIA key?

  12. Your latest version of OpenSolver2.90_AdvancedWin is triggering my virus detection software as having a Trojan.GenericKD in it. Can you scan this on your end and make sure the distributable is not infected with malicious code.

    Version 2.8.6 seems to be clean.

    1. We get this a lot. You can upload OpenSolver to, and will see that most of the virus checkers report the code as fine. The issue is with your virus checker, not with OpenSolver. Hope this helps. Andrew

  13. Hi team OpenSolver! I’m trying to automate the OpenSolver process through VBA & create a separate sheet which contains the Sensitivity Analysis to get shadow prices, but I haven’t quite figured out how/where to incorporate GetDuals. Currently running OpenSolver smoothly using Application.Run
    Thanks so much for creating this wonderful tool!

  14. Hello OpenSolver Team,

    I’m trying to install this app in order to utilize one of my company’s spreadsheets and when the app asks for my permission to run the app, I keep getting an error screen stating, “Sign in with Google temporarily disabled for this app.
    This app has not been verified yet by Google in order to use Google Sign In.”. How can I bypass this screen to use the app? Is there a way for this app to be verified so I can use it?


    Dustin Buchanan

    1. Changes made by Google mean that OpenSolver for Googlesheets is currently not working for new users who want to add it to their Googlesheets. (Apparently the first 100 users each month can sign in, but then further sign ins are blocked by Google.) We are working on fixing this, But we don’t know how long it will take, sorry. We suggest you use OpenSolver for Excel until we get it working properly for Googlesheets. Cheers, Andrew

  15. Sir,
    Since I reported OpenSolver app not to respond anymore and building its model “forever” and several attempts to reinstall failed due to auth error (trying to auth during install w/ googel acct) I never heared from anyone here again.
    Still a team out there?? I know, its freeware, but I’m just about to smash a shift rostering project (also free for my coworkers on duty) b/o I used to develop it in G-sheets, and I can’t convert it to Excel or Ooo Calc anymore due to heavy scripting and extra long formulas.
    Even my update on this “error in reinstalling” is not “reviewed” and posted…
    Any ideas? Anyone still caring about this software and the users??

Leave a Reply

Your email address will not be published. Required fields are marked *