We welcome your comments on OpenSolver.

655 thoughts on “Feedback”

  1. Hi,
    I’ve used OpenSolver Excel plug-in (2.9.3 Linear for Windows) to solve large linear optimization models in excel successfully in the past. It has been working perfectly fine for me till the last time I used it, which was around 2-3 months back. However, when I came back to it yesterday, it appears to have stopped working for some reason. I can see the OpenSolver add-in in my “Data” tab, but it has essentially become non-responsive. Clicking on buttons is not giving any response – The OpenSolver dialog box/editor that’s supposed to open doesn’t open at all.
    I was relying on this to run some optimization models, but I’m handicapped now. I tried uninstalling and reinstalling it, also tried downgrading my Office 365 – but nothing seems to work.

    Can someone please help? Would really appreciate any help I can get.

    Best Regards,

    1. Sorry it is not working. We have not changed anything. Options are Microsoft has done an Excel update that broke OpenSolver, or, more likely, your Excel installation has “broken” somehow. I suggest you try repairing your Excel installation. Also make sure that OpenSolver (and the correct version) is showing as you expect in the File…. Options…. Add-ins dialog. So, either it is not listed (in which case you load OpenSolver when you need it by double clicking the OpenSolver.xlam file – this is what I do), or it is listed as an “Active Application Add-in”. Sorry I cannot be more specific – it is super frustrating when things inexplicably break. Andrew
      PS: I don’t use Office 365, so others may have more advice for this?

      1. Thanks Andrew for a quick response. I also suspected that maybe a recent Office update broke something, so that’s why I tried downgrading my Excel version, however, that didn’t work.
        Based on your suggestion, I also tried to “repair” my installation of entire Office 365 suite of apps. Unfortunately, that didn’t fix the problem either.
        Like you said, I also always open my excel file and then open OpenSolver.xlam file which loads up the add-in to my “Data” tab. And then it also correctly appears in the “Active Application Add-in” list. So there are no issue with that.

        Anyway, I’m still looking for a solution – so Andrew, if you may have any other suggestions or anyone else who’s a user who might have faced this problem and have been able to figure out a solution – I would love to hear from you.

        1. Have you tried the latest 2.9.4 beta version? It has some fixes (but probably not for your issue). If you go back to earlier OpenSolver versions (eg 2.9.0), you will find one that is has the code “signed”. You could try a signed version to see if that helps. (The latest versions are not signed; it got too hard.)
          Please confirm you get no messages at all; OpenSolver just appears in the menus but does not work?
          You might want to check that the drive you are opening OpenSolver from is “trusted” by Excel… maybe Microsoft have hardened something? Also double check you “unblocked” the .zip download BEFORE extracting the files.
          Please let me know how you get on,

  2. Error -2147220504: Mismatched parentheses
    Non-linear parser failed while processing cell vs_B54.

    Solver: Bonmin

    B54 is the cell with the if function and it’s never wrong.
    If I remove the if function, bonmin works fine.
    Bonmin can’t handle if function?
    Can you tell me what could be causing this problem?

    1. If() functions and optimisation do not go well together, sorry. Remove the if() if you can, or solve twice – once assuming the if() is TRUE, and once with it FALSE(). You can re-create the if() using a binary variable to do this automatically. Cheers, Andrew

Leave a Reply

Your email address will not be published. Required fields are marked *